spell checking not working

For all things Mellel

Moderators: redlers, Eyal Redler, Ori Redler

spell checking not working

Postby TLS » Fri Oct 12, 2012 12:57 pm

I recently upgraded to Lion (no, not Mountain Lion). Ever since then, the Apple spell checker does not work in Mellel. I cannot seem to find a way to turn it back on.

Any ideas?
TLS
Read the guide!
 
Posts: 42
Joined: Sat Oct 22, 2005 1:48 pm

Re: spell checking not working

Postby Bulow » Wed Oct 17, 2012 12:06 pm

I have launched this subject several times, but there has been no response from the Redlers and little general interest. Please, Spellcheck, come back.
I, too, am on Lion, but I know that Mountain Lion is no better.
Bulow
Bulow
Knows everything, can prove it
 
Posts: 80
Joined: Tue Nov 25, 2008 11:49 am
Location: Paris (sometimes Copenhagen)

Re: spell checking not working

Postby Feanaaro » Fri Oct 19, 2012 7:10 am

As I wrote elsewhere:
I think I've got what the problem is, at least in my case.
For some reason, Mellel stopped assigning a language in the "character" (or is it "font" in english?) tab (the one with the T anyway). That apparently disable spell checking. If I re-assign a language to the text, then spell check is back in full swing, I notice that because apparently I had one document in which the language has been previously correctly assigned, and that was the only one in which the spell check worked.
Now if only I could get an handle of how this thing of assigning a language through the "T" tab really is supposed to work (weird place for such a setting, in my humble opinion), that would be another step forward.
Feanaaro
Got the auto-title mojo working
 
Posts: 24
Joined: Sat Oct 06, 2007 7:47 am

Re: spell checking not working

Postby Bulow » Fri Oct 19, 2012 4:52 pm

I tried this when you first wrote about it, but it does not work for me. I can make the 'Spelling and Grammar' window appear, but nothing else happens, regardless which option I take in the Edit>Spelling menu. It is as if there are no dictionaries attached.
Bulow
Bulow
Knows everything, can prove it
 
Posts: 80
Joined: Tue Nov 25, 2008 11:49 am
Location: Paris (sometimes Copenhagen)

Re: spell checking not working

Postby typofi » Mon Oct 29, 2012 3:25 pm

Indeed! This is a major problem. One that needs fixing asap. I've got OS X 10.6.8 and the latest Mellel 3.0.2. If the problem occurs with newer versions of Mac OS, like you describe, then I guess it's not just about the OS but a problem with Mellel itself.

I tried your advice and assigned languages to paragraph styles. And also tried assigning language with selecting the whole text and then from "Edit --> Spelling". Nothing. Assigning the language and restarting the program, again nothing. The option "Check spelling as you type" is supposedly on but nothing happens. Also if I try to open "Check Spelling", I just get an error beep and nothing else.

I've done all my academic writing in Mellel for several years now. And I've been promoting the software to many colleagues and friends. But if this problem isn't fixed soon, Mellel is going straight to the rubbish bin. :evil:

How can a simple feature like this be so hard to fix? Apple's default spell check works in all the other programs I have.
typofi
New to all this
 
Posts: 3
Joined: Tue Aug 05, 2008 3:18 am

Re: spell checking not working

Postby Bulow » Mon Oct 29, 2012 8:02 pm

So, come on Eyal, does your spellcheck work?
Bulow
Knows everything, can prove it
 
Posts: 80
Joined: Tue Nov 25, 2008 11:49 am
Location: Paris (sometimes Copenhagen)

Re: spell checking not working

Postby Eyal Redler » Mon Oct 29, 2012 10:05 pm

Starting from Mellel 3.0 we've made a change in the way spelling works. The way it works is this:

1. Every piece of text have a Language assigned to it (or "none") - this is set via the "Language" popup in the "Character" (and can also change as you type using various keyboard layouts)
2. For each language there is assigned a "Spelling Language" - this is done via Mellel->Preferences/Language.

For example, let's say I'm writing a text in Danish, I will need to have the following settings:
1. The text I want to spell check will need to have "Danish" assigned to it in the "Character" palette, this could happen automatically as I'm writing using the Danish keyboard layout but it could be that I have some text that has been imported from some other program or possibly with an older Mellel document that doesn't have language assignments - in this case you need to select the text and choose "Danish" from the Language popup.
2. I need to make sure that "Danish" is assigned with the appropriate spelling dictionary.
a. Open Mellel->Preferences
b. Click on "Language"
c. Locate "Danish" in the list on the left and select it.
d. Look at the popups on the right and make sure that the "Spelling Language" popup has the correct spelling dictionary selected.

And yes, it actually works for me.
Eyal Redler
----------------------
Co-Founder and Developer at RedleX
Facebook: http://www.facebook.com/mellelwordprocessor
YouTube: http://www.youtube.com/user/MellelRedlex
Did you buy Mellel via the Mac App Store? Help us by rating the app!
Eyal Redler
Co-founder
 
Posts: 456
Joined: Thu Oct 27, 2005 9:15 am

Re: spell checking not working

Postby Bulow » Tue Oct 30, 2012 12:26 am

Thank you, Eyal, it works now. I am sure you think that you have already explained it several times, but never so clearly that I could also understand. It really is quite complicated and I will see how it works when writing 3-4 modern languages and Latin on my Danish keyboard + ancient Greek on a different one. I have of course unchecked the synchronization of language and keyboard. I am very happy to have spellchecking back.
Bulow
Bulow
Knows everything, can prove it
 
Posts: 80
Joined: Tue Nov 25, 2008 11:49 am
Location: Paris (sometimes Copenhagen)

Re: spell checking not working

Postby shades » Tue Oct 30, 2012 3:56 am

Unfortunately it is still not working here: 10.8.2, Mellel 3.0.2, English. I also use Hebrew and Greek.

As soon as I quit Mellel, the preferences in the Language tab go back to nothing chosen for language on the left and “none” for each of the selections on the right.
Rich
old, slow, and confused...but at least I’m inconsistent!

iMac 21.5" (10.8 ) and MBP 13" Retina (10.8 )
shades
Knows everything, can prove it
 
Posts: 275
Joined: Fri Oct 21, 2005 12:12 am

Re: spell checking not working

Postby typofi » Tue Oct 30, 2012 7:42 am

Thank you! I got it working.

Perhaps you could make the language & spelling control a bit more consistent in future versions. Now it seems counterintuitive. Like you can assign language in the Character styles palette, but not when you are editing character styles in your Style Set. But editing paragraph styles in Style Set gives the option to set hyphenation language, which didn't seem to do much.
typofi
New to all this
 
Posts: 3
Joined: Tue Aug 05, 2008 3:18 am

Re: spell checking not working

Postby Eyal Redler » Tue Oct 30, 2012 1:29 pm

shades wrote:Unfortunately it is still not working here: 10.8.2, Mellel 3.0.2, English. I also use Hebrew and Greek.
As soon as I quit Mellel, the preferences in the Language tab go back to nothing chosen for language on the left and “none” for each of the selections on the right.


The popups on the right reflect the state of what's selected on the left. It is natural that the selection on the left resets when you re-launch Mellel since this selection is not actually changing anything but allows you to see the setting for the selected language.
Please check again for (example), Greek.
1. Open the preferences window
2. Click "Language"
3. Locate and select "Greek"
4. Make sure it has a spelling assigned to it

After that, open a document that you want to have spell checked, place the insertion point somewhere and look at the "Character" palette, does it say "Greek"? If not, make sure to select the text (or part of it, it it is multilingual) and assign a language to it.
Of-couse, you also need to have "spell as you type" turned on (Edit->Spelling)
Eyal Redler
----------------------
Co-Founder and Developer at RedleX
Facebook: http://www.facebook.com/mellelwordprocessor
YouTube: http://www.youtube.com/user/MellelRedlex
Did you buy Mellel via the Mac App Store? Help us by rating the app!
Eyal Redler
Co-founder
 
Posts: 456
Joined: Thu Oct 27, 2005 9:15 am

Re: spell checking not working

Postby raymond » Mon Nov 19, 2012 9:38 am

One more point.

I work on two or three languages document.
Is your proposed method works on this situation
raymond
Knows everything, can prove it
 
Posts: 254
Joined: Mon Dec 26, 2005 9:33 pm

Re: spell checking not working

Postby Eyal Redler » Mon Nov 19, 2012 7:02 pm

raymond wrote:I work on two or three languages document.
Is your proposed method works on this situation


Yes, that's the whole point.
As I've said before:
Starting from Mellel 3.0 we've made a change in the way spelling works. The way it works is this:
1. Every piece of text have a Language assigned to it (or "none") - this is set via the "Language" popup in the "Character"
2. For each language there is assigned a "Spelling Language" - this is done via Mellel->Preferences/Language.

If you have a document containing three languages then parts of the text that belong to a certain language need to be marked as belonging to that language and that will tell Mellel to use the spelling dictionary assigned to that language is used to check spelling that language.

Let's say your working in three languages: Hebrew, English and French. Let's also assume that your typing English using the US keyboard layout, Hebrew with the Hebrew keyboard layout and French with the French keyboard layout.
You need to first make sure the languages are configured correctly in the preferences (usually the defaults are good but it's good to check, once you did, you don't need to repeat this since the settings are global)
1. Open the preferences screen
2. Choose "Language"
3. Click "English", and make sure that both the keyboard layout and spelling dictionaries are assigned to your liking
4. Repeat 3 for Hebrew and French
5. Make sure "Synchronize Language and keyboard" is checked

Now, as you work on your document and type, for example, using the English keyboard layout, the text you enter is assigned as having the English language and the appropriate spelling dictionary is used when spell checking the text. Switch to the Hebrew layout and type - the text you've typed is assigned the Hebrew language and the spelling dictionary for Hebrew is used.
If your document was created in an earlier version or if you didn't have the synchronization on then you need to go over the text and assign the correct language to each pice of text. Find a Hebrew passage, select it and choose "Hebrew" in the language popup of the character palette. Find a French passage, select and assign and so on.
Eyal Redler
----------------------
Co-Founder and Developer at RedleX
Facebook: http://www.facebook.com/mellelwordprocessor
YouTube: http://www.youtube.com/user/MellelRedlex
Did you buy Mellel via the Mac App Store? Help us by rating the app!
Eyal Redler
Co-founder
 
Posts: 456
Joined: Thu Oct 27, 2005 9:15 am


Return to Mellel

Who is online

Users browsing this forum: Google [Bot], Yahoo [Bot] and 4 guests

cron